2018 Расклад по Excel

Microsoft Excel (MS Excel) - программа для учёта табличных данных с возможностью автозаполнения ячеек и небольших расчётов. В некоторых случаях может быть заменой программированию и специальным индивидуальным программам учёта. Хотя, впрочем, тут есть свой встроенный скриптовой язык программирования, основанный на встроенных функциях. Этот язык можно также назвать функциональным.

1. Для простой и рабочей версии без лишней шелухи можно скачать дистрибутив Microsoft Office от 2003 года. Можно галочками выбрать нужные программы при установке или установить их все. Попутно этим дистрибутивом можно установить другие стандартные и полезные программы типа Word (текст, объявления и т.п), Powerpoint (презентации) и т.д. Весит дистрибутив и программы в сумме примерно 300-400 МБ.

2. Есть также аналогичные экселю программы от других фирм, они иногда по умолчанию на компьютеры устанавливаются. Типа Calc, Libre и прочие. Их принципы работы аналогичны, мы их рассматривать не будем.

3. Открывая программу, мы видим будто бы неограниченную таблицу. Поначалу, не вдаваясь глубоко в возможности, мы просто можем писать в ячейках какой-то текст.

На самом деле эта таблица ограничена, но размеры огромные - вниз 65536 строк (2^16), направо из букв латинского алфавита после Z идёт AA, AB и т.д. до IV. Математически можно посчитать: 26 (столбцы из 1-й буквы) + 26*8 + (26-4) = 256 столбцов.

Т.е. идём мы по задумке программы в основном вниз, вписывая всё новые и новые данные. Обычно по вертикали пишут категории, а вниз по горизонтали порядковые номера всё новых и новых объектов. Например, список людей, интернет-ресурсы, даты и т.д. что угодно или что требуется для данной таблицы.


4. В одном файле можно вести несколько таблиц на разных т.н. листах - можно внизу видеть уже созданные Лист 1, Лист 2 и Лист 3. Можно их переименовать, удалить, добавить новые.

5. Можно создавать рамки для каких-то частей таблицы. Рамки находятся в правом верхнем углу. Нужно выбрать прямоугольную группу ячеек и нажать на нужный тип рамок. Рядом там также можно закрасить ячейки в нужный цвет и закрасить шрифт.

6. Наверху есть панель инструментов. По центру видим что можно изменить тип шрифта текста, размер шрифта, жирный/курсив/подчёркнутый, поставить слева (по левому краю) /по центру/справа и т.п.

7. Также там рядом (правее чем "по правому краю") есть кнопочка, с помощью которой можно объединить несколько ячеек в одну.

8. Вырезать, копировать, вставить, удалить текст - это всё очевидно. Но это можно делать.

9. Толщину ячеек в ту или иную сторону можно менять.

10. У экселя есть такая плохая фигня - автозамена текста в дату, число он по правому краю ставит и т.п. Но можно этому противостоять:

- ПКМ формат ячеек (можно одну ячейку выбрать или блок) и можно выбрать даты, проценты, дроби, десятичные дроби - что угодно что тебе нужно крч. там же можно указать число десятичных знаков после запятой. Дробную часть пишем только через запятую.

- Чтобы писать вообще что угодно, нужно поставить апостроф - после него можешь писать любой текст без автозамен. Сам апостроф не отображается.

* ПКМ - правая кнопка мыши, ЛКМ - левая

11. Возможны также гиперссылки в интернет - они автоматически засвечиваются если писать с http/https.

12. В верхней панели уже ближе к левому краю есть сортировка по возрастанию и по убыванию. Сортируется там текст А-Я. Рядом также есть кнопочка суммы (по числам) и среднее арифметическое.

13. Автоматическое расширение. Если написать 1 в какую-то ячейку, далее взять за правый нижний угол ячейки и потянуть вниз, то автоматически внизу поставятся 1. Если же при растяжении ещё параллельно удерживать CTRL, то проставляться будут 2, 3, 4 и т.д.

14. Некоторые столбцы или строки можно скрывать. На примере строк. В самое лево идём, где цифры написаны. Выделяем несколько строк, далее ПКМ и выбрать "скрыть" - всё. Это можно использовать например для промежуточных вычислений. Чтобы вновь отобразить, нужно выделить граничные строки, ПКМ и выбрать "отобразить" - всё вернётся.

15. Если начинать писать равно (=), то автоматически запускается функция- т.е. после равно подразумевается функция. И чтобы использовать функцию, нужно сначала написать знак равно. Можно не в ячейке писать, а в верхней панели рядом с маленькой надписью fx.

Теперь подробнее о том какие есть функции.

1. Арифметика с ячейками. Например, если в ячейку C2 мы напишем следующее:
=A2*B2
То в ячейку C2 автоматически попадёт умножение двух левых ячеек. Если в этих левых ячейках мы поменяем числа (данные), то в нашей С2 (где написана функция) автоматически запишется новое значение.
* Ячейки писать обязательно латинской раскладкой, иначе работать не будет. Если при наборе засветилось синим - значит всё норм. Регистр букв не важен.

Вместо умножения можно использовать другие арифметические действия: сложение (+), умножение (-), деление (/) и даже всякие логарифмы, синусы и т.п - как их правильно писать, можно посмотреть в справке - про это дальше.

2. Растягивание формул. Вот мы написали для С2 функцию. Если мы возьмём за правый нижний угол и потянем вниз, то формула автоматически перенесётся ниже: для C3 будет A3*B3 и так далее.

3. Чтобы ячейки автоматически не менялись, их можно фиксировать знаком доллар:
$C$2 - зафиксировали всю ячейку, везде так и останется С2 при растягивании
$C2 - зафиксировали только столбец С - при растягивании он останется, а вот цифра будет меняться (С3, С4 и т.п)
C$2 - наоборот, зафиксировали цифру - будет меняться только столбец (D2, E2 и т.п)

* Фиксирование работает внутри любых формул. Например, в ячейку С2 можно написать так:
=$A$2*B2
Тогда при расширении вниз для С3, С4 и т.д. будет A2*B3, A2*B4 и т.д - ячейку A2 мы тут зафиксировали

4. Функция ЕСЛИ. Имеет такой формат:
=ЕСЛИ (условие; значение если истина; значение если ложь)

* К слову, в самом экселе есть подобные краткие подсказки по каждой функции

Например, будем проводить деление - но чтобы избежать деления на 0 и не писать кракозябры из-за этого (автоматически кракозябры-ошибки) можно поступить так: если знаменатель равен нулю, то в ответе выводим 0. В противном случае производим нормальное деление. Если знаменатель равен нулю, то его как бы не существует - это считается за ЛОЖЬ. Запишется так:
=ЕСЛИ(B2; A2/B2; 0)

Другой пример - подсчёт количества нужных элементов. Пусть в А2, А3 и т.д. у нас записано время суток, в B2, B3 и т.д - сколько километров проехали. Далее столбец свободен - в нём мы подсчитаем в скольки случаях мы ездили именно утром - чтобы потом где-нибудь в другой ячейке подсчитать сумму этих случаев - сколько дней например мы ездили именно утром.
=ЕСЛИ(А2="утро";1;0)
Если утро, тогда пишем 1. Иначе 0. Тогда мы во всём столбце сосчитаем сумму этих единиц (нули на сумму не влияют) и получим как раз сколько дней мы ездили утром.

Другой вариант - выводить только те километры, когда мы ездили утром. Тогда так:
=ЕСЛИ(А2="утро";B2;0)

Мы использовали условие с равенством (A2="утро") - но могут быть также условия с использованием знаков больше или равно.

5. Функция суммирования:
=СУММ(A3:A100)
Просуммирует все ячейки от A3 вниз до A100 и выведет ответ в ту ячейку, куда мы и написали эту функцию.

6. Функция-агрегатор для суммирования и условий.
=СУММЕСЛИ(столбец для проверки условий как при сумме; само условие - текст только, значение; столбец для суммирований)

Например, из 4-го пункта через эту функцию упростим - если было утро, тогда суммируем километры.
=СУММЕСЛИ(A2:A100; "утро"; B2:B100)

Вот ещё у меня пример объединяющий 2 условия:
=СУММЕСЛИ(C3:C100;"сад";B3:B100) + СУММЕСЛИ(C3:C100;"отцсад";B3:B100)

7. Функция среднего арифметического:
=СРЗНАЧ(B3:B100)

8. Кстати, можно не весь столбец через двоеточие вводить, а просто несколько ячеек - это и для функции суммы тоже касается. Например:
=СРЗНАЧ(A2;B2;D5;E12)

Промежуток также можно использовать не вниз, а вправо:
=СУММ(A2:F2)
Просуммируются ячейки A2, B2 и т.д. до F2.

9. При написании функций надо сразу нажимать ENTER, иначе эксель думает что ты ячейку выбираешь и автоматически подставляет её в функцию. Нажатием ENTER ты заканчиваешь ввод функций. Даже когда просто просматриваешь ячейку с функцией, нажимай ENTER перед выбором новой ячейки.

10. Теперь как узнать справку по функциям - нужно чуть левее поля ввода на маленькую надпись fx нажать - там откроется окно со справкой по всем вообще возможным тут встроенным функциям. Это называется мастер функций.

По умолчанию выбраны 10 недавно использовавшихся, но можно там выбрать другие категории - по алфавиту, финансовые, математические, логические и т.п.

* В данной краткой справке я не буду рассказывать про все функции - только самое начальное и основное. Как я уже, в принципе, и начал.

11. Математические основные функции:
ABS(х) - модуль числа х.
ACOS(число), аналогично ASIN, ATAN - обратные тригонометрические функции. Возвращают ответ в радианах.
COS, SIN, TAN - тригонометрические. Аргумент по умолчанию в радианах.
EXP - экспонента (число е в степени х)
LN, LOG10 - натуральный и десятичный логарифмы соответственно
LOG(число; основание) - логарифм для произвольного основания
ГРАДУСЫ(значение в радианах) - переводит в градусы
РАДИАНЫ(значение в градусах) - наоборот
ЗНАК(х) - если х<0, то -1, при положительном 1, при нуле 0. Функция знака числа или иначе х/ABS(x) при ненулевом х.
КОРЕНЬ(х) - арифметический корень. Комплексные числа не работают.
ОКРУГЛ(округляемое число; число разрядов после запятой) - округление
ОСТАТОК(делимое A; делитель B) - вычисляет остаток (A mod B или A)
=ПИ() - просто число пи, функция без аргументов
СТЕПЕНЬ(A,B) - A в степени B
ПРОИЗВЕД - произведение чисел, аналогично СУММ
РИМСКОЕ(х) - перевод обычного числа х в римское (текстовой формат)
=СЛЧИС() - случайное число от 0 до 1, функция без аргументов, равномерное распределение
СУММКВ - сумма квадратов
ФАКТР - факториал
ЦЕЛОЕ(х) - округление до ближайшего целого
ЧИСЛКОМБ(n;k) - число сочетаний (комбинаций) из n по k. Которое ещё большой буквой С в математике обозначается часто.

12. Матричные математические функции.
Матрица образуется просто из прямоугольного блока ячеек. При вводе матрицы в качестве аргумента функции можно использовать выделение этого блока мышкой либо нотацию формата ВЕРХНИЙ ЛЕВЫЙ УГОЛ, ДВОЕТОЧИЕ, НИЖНИЙ ПРАВЫЙ УГОЛ.

Например:
=МОПРЕД(A1,C3) - определитель матрицы 3 на 3, где матрица в ячейках А1, А2, А3, В1, В2, В3, С1, С2, С3.

Бывает, что результатом является матрица. Для функций:
=МОБР(матрица) - обратная матрица
=МУМНОЖ(первая матрица; вторая матрица) - умножение матриц

Как вывести эту матрицу? Сначала просто записываем функцию в той ячейке, которая будет у нас левым верхним краем результирующего массива. Далее выделяем нужную нам область, где у нас будет результирующий массив. Нажимаем F2. Далее одновременно нажимаем CTRL + SHIFT + ENTER. Всё, результирующий массив появится в этой выбранной нами области.

При нажатии на ячейку с результатом чтобы выйти оттуда (будет постоянно "нельзя изменять часть массива" когда ты нажимаешь на какую-то ячейку), нужно нажать красный крестик левее значка-надписи fx.

13. Другие категории функций.

* Финансовые - список финансовых функций. Их много, перечислять не буду - там в справке всё написано.
* Функции даты и времени.
* Статистические функции - и в т.ч. там вероятностые. Разные способы расчёта вероятностей, статистических распределений по Бернулли, Гауссу и т.п.

Отдельные некоторые статистические:
=МЕДИАНА (перечисление элементов)
=МОДА (перечисление)
=МИНА или =МАКСА - минимальное и максимальное значения
=МИН, =МАКС - тут игнорируются логические значения и текст, чисто для чисел
=НАИБОЛЬШИЙ(перечисление или столбец, массив; какой по счёту наибольший), аналогично =НАИМЕНЬШИЙ
=СЧЁТ(перечисление) - выводит (возвращает) количество чисел в списке аргументов.
=СЧЁТЕСЛИ(столбец где считаем; условие при котором считаем) - считаем количество только если соблюдается выбранное условие
СРГЕОМ - среднее геометрическое
СРГАРМ - среднее гармоническое

* Функции ссылок и массивов
* Функции работы с базами данных

* Текстовые функции - для работы с текстом. Перечислять не буду, там можно посмотреть и покопаться подробнее при необходимости. Можно например сделать все буквы строчными, повторять какой-то текст, заменять старый на новый и т.д. и т.п.

* Логические и проверочные функции - их отдельно ниже следующими пунктами.

14. Логические операции
Тут есть стандартные и, или - но они существуют только в виде функций.
=И (перечисление условий) - возвращает истину или ложь, можно использовать как вложенную функцию в других функциях.
Аналогично ИЛИ, НЕ. Также можно просто вернуть =ИСТИНА() или =ЛОЖЬ() сами как значения.
И ещё функция ЕСЛИ, которая нами уже рассмотрена.

15. Проверочные функции - или подписано как "проверка свойств и значений"
Обычно возвращают истину или ложь - проверяют, соблюдается ли что-то. Некоторые функции тут приведу:

=ЕНЕТЕКСТ(значение ячейки например) - если не текст, то возвращает истину. Иначе ложь.
Подобные функции можно использовать как подфункции в других функциях, в частности ЕСЛИ.
=ЕСЛИ (ЕНЕТЕКСТ(что-то там); значение если истина; значение если ложь)

Таким образом получается даже простейшее небольшое программирование прямо тут, в экселе. Можно реализовывать простой учёт данных с помощью всех этих средств.


На этом работа с excel не ограничивается - тут есть ещё возможность создания диаграмм разных видов: столбчатые, круговые и т.п. Для этого в верхней панели есть соответствующая кнопочка, подписанная при наведении как мастер диаграмм. Также там рядом есть рисование.

В рисовании можно добавлять картинки, делать фигуры разные - в том числе и трёхмерные. В общем, некая такая простая визуализация. Подобное и в PowerPoint'е можно видеть.

А ещё тут есть макросы - такие небольшие программки (или скрипты, алгоритмы), которые интегрируются в excel и тут используются. Подобное существует и в других программах MS Office. Но про это всё подробно сейчас не будем - возможно лишь в новых и дополненных версиях сего расклада. Для написания макросов используется язык программирования Visual Basic for Applications или сокращённо VBA. Можно писать как в самом Excel в т.н. макрорекордере (для версии 2003 сервис -> развернуть -> макрос -> начать запись или редактор) или отдельно писать, а потом прикрутить. Тема долгая и является условно финальной стадией развития в excel - это ещё даже круче чем функции, если в этом разобраться. Такое небольшое встроенное программирование.

Кисмур Мусин, 11.06.2018, Казань.


Рецензии